Welcome to the forum   
Welcome Guest! To enable all features please Login or Register.



Go to last post in this topic Go to first unread post in this topic
Offline Jan Flikweert  
#1 Posted : 11 July 2022 13:37:16(UTC)
Jan Flikweert

Joined: 08/07/2015(UTC)
Posts: 4
Location: Berkenlaan 34
Mellow I obtained software version 0.90 of Railuino but I am having problems getting it working.

Does anyone have it working?
If yes what is your version?
and what is your configuration?
-Arduino used?
-Shield used?
-Pins used?
-From which site did you download your software? And what needed changing in the Software?
I would appreciate your help!
Thanks in advance/
Jan Flikweert

-So far a downloaded 0.90 software.
-Solved a compiler error.
-Solved compiler warnings.
-Managed to get MCP2515 8MHz shield to work. At least the test suit managed to put power on, Did move the locomotive and did put a function light on and of again. (Using
Marklin 60116. Mobile Station does not need to be connected). I used an Arduino Nano. (Conflict with Arduino Uno that uses the same AVR identifier solved). It looks like the setup can output but
no input and no interrupts.

In my project, I tag HO material with RFID tags. Everyone is unique and identifies for instance a locomotive or other HO material. I can detect which RFID passes the reader and that triggers a signal to the Arduino.
Examples of actions could be: Stop locomotive on red, reduce speed on yellow, turn the front light on, on tunnel entrance, give special signals when filling steam locomotives with water, etc. So far I managed to the RFID part working but before I continue with it I need to control the locomotives' actions.

I would appreciate some help?

Edited by user 12 July 2022 15:25:19(UTC)  | Reason: Not specified

Offline Unholz  
#2 Posted : 11 July 2022 19:05:25(UTC)

Joined: 29/07/2007(UTC)
Posts: 1,357
Location: Switzerland
In case somebody searches this forum with specific keywords: I think the stuff is called Railuino (different spelling).
Offline Jan Flikweert  
#3 Posted : 12 July 2022 15:51:37(UTC)
Jan Flikweert

Joined: 08/07/2015(UTC)
Posts: 4
Location: Berkenlaan 34
Thanks. My mistake. I corrected it.

Talking about it or writing about it helps. I made some progress with the test program. Interrupts are now working.
Still interested in the information.

Additional information about my environment.
The Arduino development software has version 1.8.19. I am working with Visual Studio Community version 2022 which has a plugin from vMicro (visual Micro.
I believe this software is owned by Atmel but I could be wrong) that encapsulates the Arduino software.
The last part has to be paid per year. (I believe less than 20 euros annually for the hobbyist. It makes my life much easier.

I wait and keep you up to date.
Kind regards,

Offline David Dewar  
#4 Posted : 15 July 2022 21:19:40(UTC)
David Dewar

Joined: 01/02/2004(UTC)
Posts: 7,175
Location: Scotland
Sorry I cant help but it is good to know that I might not be the only one who has not a clue what this is about.
Peter on here is a genius with computer type control if he sees this and can help.
Take care I like Marklin and will defend the worlds greatest model rail manufacturer.
Offline Jan Flikweert  
#5 Posted : 17 July 2022 23:30:12(UTC)
Jan Flikweert

Joined: 08/07/2015(UTC)
Posts: 4
Location: Berkenlaan 34
Sorry about that David. But all I want is a working set of the Railuino software.

The other information has more to do with my working environment. It might be that someone who has a working set recognizes something wrong in my setup. After all, I make mistakes!
But having said that. The test program that comes with the downloaded Railuino software tells me that I am now down to 21 out of 22 tests that are correct. So I am making progress in solving my problems.

If you have never heard of Railuino software this cry for help was not meant for you but if you have, you can bring me in contact with a person that uses it.

Anyway thanks for your time,
Jan Flikweert

Offline Jan Flikweert  
#6 Posted : 20 July 2022 17:20:00(UTC)
Jan Flikweert

Joined: 08/07/2015(UTC)
Posts: 4
Location: Berkenlaan 34
Hello readers,
I fixed it myself. Railuino software finally works. So, the request for information can be closed.
Jan Flikweert
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

| Powered by YAF.NET | YAF.NET © 2003-2023, Yet Another Forum.NET
This page was generated in 0.365 seconds.