Welcome to the forum   
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Share
Options
View
Go to last post in this topic Go to first unread post in this topic
Offline mike c  
#1 Posted : 21 May 2020 03:49:27(UTC)
mike c

Canada   
Joined: 28/11/2007(UTC)
Posts: 6,661
Location: Montreal, QC
I recently ordered the Liliput 133931 4 car SBB RABe 511 set after having ridden on this train between Sargans and Zurich last summer.
The intermediate coach add-on set was very hard to find and I ended up ordering it from a dealer in the UK.

So that bring us to the question... Which will arrive at my doorstep first, the main set with pilot coaches from Switzerland or the intermediate coach set from England?

I already have the 133930 model in the blue and white S-Bahn Zurich livery.

This was not an inexpensive model and probably came out to more than the announced Maerklin RAm.

I like the way the model I have runs, but I worry about it's longevity compared to Maerklin and Roco models.

Regards

Mike C

Offline mike c  
#2 Posted : 26 May 2020 16:58:44(UTC)
mike c

Canada   
Joined: 28/11/2007(UTC)
Posts: 6,661
Location: Montreal, QC
I was very happy this morning when Canada Post informed me that the package with the main set was scheduled for delivery today.
It came a little over an hour ago. I disinfected the outer box and then waited about a half hour before opening the parcel with gloves and mask.
I placed the model on my test track, after having to reinstall two wheelsets that had popped out in the box.
The model works very nicely.
It was at that moment that I noticed that the white LEDs on the end facing away from me were not activating. The destination sign was illuminated, the red LEDs went on when it was at the rear of the train, but the white LEDs were not going on. The interior lighting responded to F1.
I left the train on the test track. I will test it later with either my MS2 or with my ESU Lokprogrammer, just to have a second opinion.
In the meantime, I sent an email to the dealer acknowledging receipt and advising them of the LED issue.

It is a little frustrating that once again, a model that costs around $1000 arrives with a minor issue that most likely will require a costly return for repairs.
I don't have the optical dexterity to open the model and check all of the wiring/circuit to troubleshoot electronically/electrically.

Regards

Mike C
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

| Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.187 seconds.