Welcome to the forum   
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Share
Options
View
Go to last post in this topic Go to first unread post in this topic
Offline MKOpSeattle  
#1 Posted : 04 August 2019 03:33:53(UTC)
MKOpSeattle

United States   
Joined: 29/12/2013(UTC)
Posts: 122
Location: Seattle, WA
I have a MS2 (60653) with SW 2.5 and Connector Box (60113) since 2015. They were working fine until a few days ago. The MS2 just froze while a lok was running. The display was still lit but all the buttons stop responding, including the STOP button. I had to turn off the main power to stop the lok.

I powered it up again and the MS2 display was blank. I switched to the second input on the Connector Box and it was working fine for a day. Then the same problem happened. When the problem first occurred, the lok was running and MS2 display was lit. That led me to believe the problem was with the MS2 and not the Connector Box. Do the experts in the forum agree with my diagnosis?

I thought maybe it's time to get a new MS2 with the latest SW. I'd like to know if I need a new Connector Box also. Thanks.
Offline morsing  
#2 Posted : 04 August 2019 10:50:31(UTC)
morsing

United Kingdom   
Joined: 16/08/2014(UTC)
Posts: 424
Location: Aylesbury, Buckinghamshire
Hi,

I don't know about your specific problem, but I have both for sale if you need them.

Thanks
-----
Modelling west Denmark era IV - possibly with some out-of-place elements!
Marklin C-track + CS3
6m2 layout to be controlled by RocRail
Offline Jabez  
#3 Posted : 04 August 2019 17:14:43(UTC)
Jabez

Belgium   
Joined: 30/08/2016(UTC)
Posts: 620
Location: Brussels
Have you tried a factory reset of your MS2. This usually solved any problems that arose with mine.
Jabez
I heard that lonesome whistle blow. Hank Williams
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

| Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.188 seconds.