Welcome to the forum   
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

7 Pages«<34567>
Share
Options
View
Go to last post in this topic Go to first unread post in this topic
Offline Tivvy  
#201 Posted : 23 October 2008 10:13:07(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Alessandro, if you were to connect more s88 contacts you could overcome the problem quite easily I think. For example if you make a short contact track ~90mm before the signal. You can set the speed of the train to say 30km/hr which is an appropriate speed for entering a station track where you are currently telling the trains to brake, and then set the speed to 0 when the train reaches the short s88 contact in front of the signal. Braking any train from 30km/hr will only take a very short space and that way you have a longer slow down from your trains and still be sure they will clear the points. Smile

Great video none-the-less (even if it did take 20 minutes to download downunder). biggrin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline frankie  
#202 Posted : 23 October 2008 10:26:00(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
One other thing is that the layout was planned to be operated conventionally, then the signals have the isolated track, which on a PC controlled one is not needed.
Alessandro
I have a CS1 Reloaded!
Offline mascagni  
#203 Posted : 23 October 2008 12:40:43(UTC)
mascagni


Joined: 25/07/2002(UTC)
Posts: 804
Location: Tallahassee, FL USA
Alessandro: Molto bravo, auguroni (continuo in ingelese)...

I noticed that the lights on the trains often went off when they stopped. In addition, there was a relay sound. Did you use a k84 to turn off and on certain tracks that were used to park the trains. If so, I guess I am interested in knowing why that is an different than just commanding the train to zero speed. It is clearly safer, as a decoder could act up, but why do you do it that way (if my ear really noticed correctly)?

Grazie per il video.--MM
Michael Mascagni, Tallahassee

If I weren't a Mathematician, I'd be a Violinist.--Albert Einstein
Offline frankie  
#204 Posted : 23 October 2008 13:25:27(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
I guess the relay sound is just the switches moving the points, the lights go off because the layout was built to be operated conventionally, then there is an isolated track section corresponding to the signal position.
The two Viessmann signals 4011 are controlled by an Uhlenbrock 44200 brake module, which are still operational, the other signals are Marklin.
If it would have been built with the intention of controlling it from the PC from the start k84 and 4011 would have been the right choice, I guess.
Setting a condition Hp0-&gt;Train 1 speed=0 makes the train slow down and then stop, like with a brake module, you use the loco decoder setting to stop the loco just like the real thing.
Is this that you meant?
Alessandro
I have a CS1 Reloaded!
Offline mascagni  
#205 Posted : 23 October 2008 14:42:05(UTC)
mascagni


Joined: 25/07/2002(UTC)
Posts: 804
Location: Tallahassee, FL USA
Alessandro: Yes, using the loco decoder to stop seems fine. However, you stop very close to the switches, and my experience is that there is some variability in the behavior form instance to instance. Thus, one would expect that with some nonzero probability a train may over run the area designated for the stop, and this would potentially cause problems if that track past the designated area is not monitored by an s88 signal. I have not yet gained the personal experience, and so I am curious how variable these things really are.--MM
Michael Mascagni, Tallahassee

If I weren't a Mathematician, I'd be a Violinist.--Albert Einstein
Offline dntower85  
#206 Posted : 23 October 2008 16:30:16(UTC)
dntower85

United States   
Joined: 08/01/2006(UTC)
Posts: 2,216
Location: Shady Shores, TX - USA
I turn the braking and acceleration off or set it very low. To avoid passing a signal or crossing a switch. even then I can only get the train to stop with in a 4 to 6 inch area, add more for older delta's.
I think this is do to the slow data rate of the 6051. If I add more contacts I don't know if the 6051 can process it fast enough and send the data to the computer then send the command back to the loc before the train get to the next contact. I need two more S88 contacts to get the train to slow down into the station, one day I'll get another s88 and set it this way, till then I have to stop the train rather fast.
DT
Now powered by ECoS II unit#2, RocRail

era - some time in the future when the space time continuum is disrupted and ICE 3 Trains run on the same rails as the Adler and BR18's.
Offline frankie  
#207 Posted : 23 October 2008 16:39:16(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
It takes a lot of fine tuning to make sure that the train stops spot on, like reducing the delay on the action by 50 ms at a time, my problem actually is not the overrun of the signal, but the train stopping to early and not clearing the switches.
The fact that the signals still work in conventional mode is somehow a safety, because you get the lights off, but at least they are not going to overshoot.
Sometimes you have a big change if the loco runs with the pick-up forward or back.
One thing I haven't tried, [:I]but requested the feature[:I], is to group part of the action in a route where you have an extra setting for the timing of the execution of the respective actions.
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#208 Posted : 23 October 2008 18:24:33(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Alessandro,

Is it not possible to work with 4 sections and 3 blocks before the signal? A stop, break/slow-down and 'free' block based on a small contact rail.
The train set should not be longer than the first 3 sections.

Then a set of conditions could be defined that triggers only the switch/turnout when the stop block and or break block gets occupied, train speed = 0/Hp0 is on and block 3 is no longer occupied(free). Indeed a lot of options are possible, depending on how many occupancy detectors you want to spend and the complexity of the conditions rule(s) in the Actions and Conditions definitions in LC.

Ciao,
Frank
Offline mascagni  
#209 Posted : 23 October 2008 19:57:50(UTC)
mascagni


Joined: 25/07/2002(UTC)
Posts: 804
Location: Tallahassee, FL USA
Alessandro and Frank: Thanks for the answers. I think to make things truly automatic you have to metaphorically wear suspenders and a belt. One problem that we programmers always run into is that there are often uncountable failure modes, and hence it is impossible to trap all of them in some logic.--MM
Michael Mascagni, Tallahassee

If I weren't a Mathematician, I'd be a Violinist.--Albert Einstein
Offline fvri  
#210 Posted : 01 November 2008 14:56:12(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi,

LC version 1.0.0.21 is just released. This version fixes a bug when using the 'Actions and Conditions' concept with the Delay parameter.



UserPostedImage


Thank you Alessandro(Frankie) for reporting this problem.

Best regards,
Frank
Offline Bigdaddynz  
#211 Posted : 01 November 2008 20:33:01(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Thanks Frank, I wonder if this will fix my problem - multiple actions defined, but only one triggering? I also had the delay set.

I shall download and try! Thanks once again.
Offline frankie  
#212 Posted : 01 November 2008 22:34:20(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
That's exactly it, multiple actions with multiple SINGLE conditions, but the first condition ruled as a GLOBAL.
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#213 Posted : 02 November 2008 10:19:41(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi David and Alessandro,

I hope this latest version 1.0.0.21 will fix the problems that you both experience with the Actions and Conditions...

It can be tested in Test Mode.

David, if you are still having problems could you please send me your layout file and indicate which contact should be triggered to reproduce the problem.

BTW David, I have improved copy/paste operations so that converting from a layout with more than one table to one with multiple layers makes it easier.

Thank you both for the feedback.

Best regards,
Frank
Offline Bigdaddynz  
#214 Posted : 02 November 2008 10:45:03(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
It seems v1.0.0.21 hasn't fixed the problem for me. I've sent my layout file to you, Frank. Thanks very much.

Seems to work fine in test mode, but not in operational mode. Sensors are definitely activated.
Offline fvri  
#215 Posted : 02 November 2008 20:38:51(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Dave,

The latest bug fix (version 1.0.0.21) is not really related to your problem. In Alessandro's case the 'single' conditions are playing a role.

In your case some timing issue seems to be the problem.

I will simulate the behaviour of a reed relais to try to reproduce the problem your are facing with the execution of the actions in automatic operation mode.

In my case I have only contact rails in my layout and all actions are always executed.

I will let you know if I have found something.

Best regards,
Frank
Offline Bigdaddynz  
#216 Posted : 03 November 2008 20:28:49(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Thanks Frank, much appreciated!
Offline fvri  
#217 Posted : 03 November 2008 22:43:08(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Alessandro and Dave,

I reviewed the coding many times and did several tests on my layout but, unfortunately(?), I could not reproduce the problem you both are having with the automatic operation mode and the multiple actions.

<u>So what did I do?:</u>
- First, I created 16 actions one set of actions(8) switches 8 different double slips(DS1 until DS8) to the cross state, the other 8 actions switches the same 8 double slips to don't cross state.

The first 8 actions have a single condition signal L1 is Hp1(green) the other actions have each a single condition signal L1 is Hp0(red).

UserPostedImage


UserPostedImage

And I used different values for the delay parameter.


- Then I ran LC in automatic operation mode and triggered the contact rail very shortly with L1 set to Hp1 and then I did the test again by switch the signal L1 to Hp0 and triggering again the same contact rail shortly.

In the movie you can see that all double slips DS1 until D8 are switched all correctly after triggering the contact rail (left side, block is becoming orange), depending on the state of the signal the state of the double slip is set.

http://users.telenet.be/loccommander/LCMovies/Actions.exe

Further the only difference we still have is probably the PC and the digital system(Central Station), I'm using an ECoS as digital system.
Thus normally I would think a PC performance issue, but..?

I have done the test at least 50 times and never one action was lost.[:I]

Nevertheless, I have uploaded a new version of LC with an extra check when the delay parameter is set. Although I don't have any problems with the version of 1/11/2008. The bug fix I did was related to the single condition in the Actions and Conditions dialog.

So, if you have some time to test, please download again LC version 1.0.0.21 (build date:03/11/2008).

Any other testers are welcome!

Best regards,
Frank
Offline frankie  
#218 Posted : 04 November 2008 09:26:54(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
I thought it could be network performance, because in my case I have used an old access point to connect the CS to my network, then I reverted to a cable, it's just about the same.
The only thing I can think of is Vista vs. XP, I believe you compile the binaries on there, right?
Any chance you can do it on an XP machine?
I can try on the software on a Vista running PC, on the other hand.
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#219 Posted : 04 November 2008 10:31:43(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Alessandro,

LC is (g)crap (Dutch, sorry) if it can't handle not even 2 actions as in the setup of Dave.[:I]

As stated earlier I did more than 50 tests yesterday with 16 defined actions and I never lost one...

Actions are executed in a seperate thread and new commands are only executed after a reply is send from the digital system.

Sorry, but, I can't longer compile it on an XP system, although I think this will not play a role. In the latest version I added an extra check that only destroys the 'actions' thread when all actions are executed, at least all actions are send to the digital system and foreach a reply is send back.

I really can't belief it is a CPU performance issue, if it also fails when only a few actions are defined.

I also find out although I wait until I get a reply from the ECoS before sending a new command when a flood of commands is sent the ECoS reboots... It seems it already sends a reply but its incoming buffer can still go in overflow ???

Alessandro I hope some other guys can share their experience but I'm afraid[:I].

Alessandro, but in version 1.0.0.17 you don't have this issue? It could be that this version was build on a XP system....[:I]

Thanks for the feedback!

Ciao,
Frank
Offline Bigdaddynz  
#220 Posted : 04 November 2008 10:59:10(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Hi Frank, I have had another try with your latest build (v1.0.0.21 b03112008), and I think I have worked out why things were not working properly for me. I noticed that on the properties page for each individual signal / turnout, not every 'automatic' button was depressed, even though the layout was running in automatic operational mode. Ensuring all the 'automatic' buttons are depressed on each solenoid device meant that the actions and conditions work as intended. I had turned off any delay, but I will try (maybe tomorrow night) with some delay turned on.

Now and then an action can get missed, this seems to coincide with removing the windows focus from LC, such as going to the web browser to type in the forum.

I'm running XP SP2, it probably won't hurt to upgrade to SP3, etc.

I'll also get around to setting up the other side of the station area, so that I can run 4 trains under automatic control.

Thanks for all your help with this. BTW, your software ain't crap!
Offline frankie  
#221 Posted : 04 November 2008 11:15:59(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
I can still run version 1.0.0.17 on an older laptop I have set aside, I will let you know.
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#222 Posted : 04 November 2008 12:15:31(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Dave,

When running in 'Automatic' operation mode automatic mode is switched off when a controllable object(train, turnout, signal) is manually operated in LC by the user. Only for the object that was manual controlled. To bring it back to automatic mode press the 'Automatic' button, or just switch in the Running mode toolbar button to 'Manual' and back to 'Automatic', in this way you are sure all controllable objects are back set to 'Automatic' mode.

But in some way I should make this behaviour for switching between automatic and manual more user friendly. I myself also forget sometimes to set it back to automatic after controlling it manually. This could lead to serious problems on your layout.[:I]

"Now and then an action can get missed, this seems to coincide with removing the windows focus from LC, such as going to the web browser to type in the forum."

Dave it worries me that this focus out could influence the execution of the automatic actions ... [:0]

What I sometimes experience that connection is lost between ECoS and PC when there is no activity. The only way to regain connection is by going to the network DHCP window on my ECoS and reset it the assigned IP address. But, I think this might be some router issue.

Thanks anyway for your report Dave! Yes Dave I should not say that it is crap but in some way I'm a little bit frustrated as I can't help you guys out as I can't see anything going wrong at my side.

Best regards,
Frank
Offline Bigdaddynz  
#223 Posted : 04 November 2008 20:33:13(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Don't worry Frank, we'll get there! At least I've progressed from where I was. I'll do the SP3 / patches things and go from there. I probably don't have enough memory in the PC to upgrade to Vista ([xx(][xx(] - now Vista, that is CRAP!) at this point in time....
Offline Tivvy  
#224 Posted : 05 November 2008 00:39:41(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
My new lappy came with Windows <s>Vista</s> sh-tsta - and I think it is terrible, completley unstable even with all the latest updates etc....
So I would stick with XP for as long as you can BigDaddy[}:)]
Anyway that was off topic. Sorry Frank.

Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline Bigdaddynz  
#225 Posted : 05 November 2008 03:22:58(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Can't say I disagree Caillin! I use Vista at work, mainly to get familiar with it, before it gets unleased on Joe User, but I don't particularily like it. They seem to have made changes for changes sake. I believe Vista is a bit more 'secure', but functionaily wise I prefer XP. Oh, and the machine footprint for Vista is much higher!!
Offline fvri  
#226 Posted : 05 November 2008 10:08:38(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Caillin and Dave,

As I only use my Vista system to develop and to run LC, I don't(didn't) experience any serious problems(yet) with Vista.

I must agree I don't see any benefits in regard to XP. But, I don't complain. The only thing I experience as 'anoying' is the security concept in Vista.

Cheers,
Frank
Offline fvri  
#227 Posted : 09 November 2008 18:37:06(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi all,

Version 1.0.0.22 is released.

Added semi-automatic operation mode next to manual and (full) automatic mode.

In this mode the user is allowed to manual control switches and trains. But the user needs to give back control to the system when manual control is no longer required. In (full) automatic mode the system 'fully' controls the objects based on the actions and conditions defined in the 'Actions and Conditions' dialog, no longer manual control is allowed (like in previous versions...).

Further fixed some bugs [:I] and added two new toolbar buttons.

Best regards,
Frank
Offline Bigdaddynz  
#228 Posted : 12 November 2008 04:03:24(UTC)
Bigdaddynz

New Zealand   
Joined: 17/09/2006(UTC)
Posts: 13,715
Location: New Zealand
Hi Frank, I can report that I've set up the other half of my station for automatic running, and that both sides are running as intended under LC (that's is apart from one brain fade moment where I set one of the actions for a signal incorrectly, and wondered why it wasn't going to Hp2 - it was set to Hp00!).

LC v1.0.0.22 certainly makes it easier to determine whether the layout is under full LC automatic control, as in automatic mode everything is locked out and you cannot make changes until you go to semi automatic mode. That's a good feature.

Thanks for all your hard work!
Offline fvri  
#229 Posted : 12 November 2008 09:38:24(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Dave,

Fine to hear that everything works fine now...!
I'll will try to do my best to improve as much as possible in LC.

Do you use already the counters (related to the feedback item type) in the 'Actions and Conditions' dialog?

Don't hesitate to give suggestions or to report trouble shooting!

Thanks for the feedback!
Frank
Offline frankie  
#230 Posted : 12 November 2008 09:49:30(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
I have found out that if you have two trains that do exactly the same actions, the only way to separate them at some point is using the counters, I have still to implement this, but I will let you know how it works.
BTW the three actions possible are increase the counter by one, reset it to zero and the double plus sign? What does it mean?
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#231 Posted : 12 November 2008 12:42:43(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Alessandro,

In the following topic :
http://fvri.forumco.com/topic~TOPIC_ID~51.asp
the counter stuff is explained.

Also in the updated LC manual you will find some explanation regarding this counter variable in the 'Actions and Conditions' dialog.

BTW. the Counter++ is a C++ syntax and it is used for incrementing the value of a variable by one! wink

If any shortcomings please let me know!

Ciao,
Frank

Offline frankie  
#232 Posted : 12 November 2008 13:08:00(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
Thanks, sometimes I am too lazy [:I]
Alessandro
I have a CS1 Reloaded!
Offline Tivvy  
#233 Posted : 13 November 2008 09:32:35(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Hi Frank,

Would it be possible to make routes a on/off type object?
If that could be done then could it also be added as an possible condition for the actions/conditions box?

This would mean that you could make routes a mutually exclusive event which would make organising large switching yards a lot easier than having to have conditions relating to hundreds of individual points when entering a switching area.

Also, are you going to implement the twin motor DS switch at all?

Thanks a lot
Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline frankie  
#234 Posted : 13 November 2008 09:48:16(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
Routes can already be set in the "actions and conditions" dialog and executed or not based on the fulfillment of a condition, it's that what you mean?
Alessandro
I have a CS1 Reloaded!
Offline Tivvy  
#235 Posted : 13 November 2008 10:12:43(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Not quite Alessandro.

What I would like to be able to do it make a route and on/off feature so that I could have a condition statment like:
IF route 3Ato4OUT is OFF
then set route XXX on.

Basically I would have a large number of routes connecting each of the station tracks and the entry/exit tracks. Then as a train activates an s88 when trying to enter the station it will automatically set a route to a station track and let the train through. However I dont want it to set the points or let the train go if there is another route active that crosses the route of the incoming train. Once a train clears the point zone (gets to the platform) it would then switch the route 'off' which would allow other trains through.

The simple way would of couse be to only allow one train in the switching zone at any time but with the size of the yard I would like to control there would always be queus of trains waiting that would normally be able to proceed to a platform.

Hope that makes sense to you.

Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline Tivvy  
#236 Posted : 13 November 2008 10:13:47(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Quote:
[size=1" face="Verdana" id="quote]quote:Originally posted by Tivvy
<br />Not quite Alessandro.

What I would like to be able to do it make a route and on/off feature so that I could have a condition statment like:
IF route ZZZ is OFF
then set route XXX on.

Basically I would have a large number of routes connecting each of the station tracks and the entry/exit tracks. Then as a train activates an s88 when trying to enter the station it will automatically set a route to a station track and let the train through. However I dont want it to set the points or let the train go if there is another route active that crosses the route of the incoming train. Once a train clears the point zone (gets to the platform) it would then switch the route 'off' which would allow other trains through.

The simple way would of couse be to only allow one train in the switching zone at any time but with the size of the yard I would like to control there would always be queus of trains waiting that would normally be able to proceed to a platform.

Hope that makes sense to you.

Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline frankie  
#237 Posted : 13 November 2008 11:01:39(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
Yes it does, you can put a route in the action dialog, it's a feature I requested Frank to implement, but I cannot remember, right now, if you can use them in the conditions dialog.
You can use a specific action or more than one, included in your route, as a condition though.
If route ZZZ sets S1 to Hp0 and LT2 to "left", then you can use them as a condition to execute or not another action/route.
Moreover as your train proceeds through the station it should activate other s88 to free the tracks behind, LC is not able to "queue" an action they have to be activated some way.
Alessandro
I have a CS1 Reloaded!
Offline Tivvy  
#238 Posted : 13 November 2008 12:57:18(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Problem with just using individual turnouts as a condition is that there would be a lot of sub conditions and given the size of the yard I am planning on there would be a 50-100 conditions on every routes activation! Alternatively, if I could do it using routes then there would be approximately 10 conditions which is far more manageable.

You mention that LC cannot queue actions. If the s88 remains in contact then will it keep checking for the fulfillment of conditions until the s88 is cleared?

Thanks for all your help.
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline fvri  
#239 Posted : 13 November 2008 13:15:04(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Quote:
[size=1" face="Verdana" id="quote]quote:Originally posted by Tivvy
<br />
You mention that LC cannot queue actions. If the s88 remains in contact then will it keep checking for the fulfillment of conditions until the s88 is cleared?


Actions...

Yes, correct Caillin, as long as the track remains occupied LC will continue iterating over the actions and check if the conditions are fullfilled.

However when all conditions are fullfilled and thus all actions are triggered the 'Actions'-thread is stopped even when the track is still occupied. Is this behaviour acceptable ? I did this to reduce process resources.

When the 'Delay' parameter in the 'Actions and Conditions' dialog is set it is a one shot only. It does not repeat checking the conditions when the track is still occupied and/or not all conditions are fullfilled.

I hope this makes things more understandable regarding the actions concept.

About the routes?

Currently, there is nothing in the Actions and Conditions concept that implements rules for routes. Only actions.

Thus you would like to know when a route is active? Thus when LC is executing the actions in the route? I could define a condition Route is Active and Route is Not Active.

Please correct me if you think otherwise.wink

Cheers,
Frank
Offline Tivvy  
#240 Posted : 13 November 2008 13:54:23(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Hit it in one Frank.

Re the actions, that is fine. Once a train is "cleared" through to the station (or out of it) then the route is set active and that is all the s88 needs to worry about, the condition shouldnt repeat itself until the next train comes along.
Hopefully that train will not be running into the back of the other train....[}:)]

With the routes that is exactly what I am after, the condition of the route being "active" and "not active" and the ability to use this in condition statements. Smile

Thanks a lot to both you and Alessandro.
Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline frankie  
#241 Posted : 13 November 2008 14:36:40(UTC)
frankie


Joined: 27/10/2006(UTC)
Posts: 692
Location: Italy
I mostly use contact tracks, not the isolated ones, then my assumption was related to the fact that some trigger has to occur.
In fact as long as the track is occupied and a condition, even transitory, is fulfilled the actions are executed.
I can see the point of Caillin, the train is stopped at the entrance of the yard/station and is waiting for the other train to clear the route, but then what will be the trigger for the route set in "off"?
Alessandro
I have a CS1 Reloaded!
Offline fvri  
#242 Posted : 14 November 2008 12:57:45(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Caillin,

Indeed Alessandro is right, what should trigger the off/'not active' state ?

Yes, the 'double slip with '4 states' is implemented but, I could not test it as I don't have one. Thus feel free to do so.wink

Cheers,
Frank
Offline Tivvy  
#243 Posted : 14 November 2008 14:11:59(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Frank,
The trigger would most likely be a contact track at the end of the station or the length of a full train outside the yard area. It would also trigger a change of signal states.
If implemented then I suspect you would have to make it an optional feature for each route so that current routes action/condition logic isnt destroyed.

Sorry I just realise I am about couple of versions behind so I missed the 4-state DS switch. Updating to the latest version now. Smile

Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline fvri  
#244 Posted : 14 November 2008 15:01:25(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Caillin,

About the DS with 4 states, I know it does not correctly work with the 6021/6051 (Bart alias dikken) but, it should be ok with the ECoS or CS systems.

Ok, thanks for the input on the route stuff, I will think about it some what more.wink

Professionally, I have a lot of time pressure at least until next year February. But, I will see what I can do after 12 hours coding during the day.biggrin

Cheers,
Frank
Offline dikken  
#245 Posted : 15 November 2008 02:21:41(UTC)
dikken


Joined: 22/10/2003(UTC)
Posts: 376
Location: blankenberge,
hi frank,

As soon as I find my way back to the attic I'll update you on the DS4S!
Dikken

Check out my site:
http://www.modelspoorhobby.be
Offline fvri  
#246 Posted : 16 November 2008 16:44:27(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi all,

I have released a newer version of LC 1.0.0.22 (build date 16/11/2008).

This maintenance release implements:
- the feature request (Caillin) : route object with conditions and a new route action, 'Set Not Active' in the 'Actions and Condition' dialog.


<u>1. The new Route Action : Set Not Active.</u>

UserPostedImage

<u>2. The new Route Conditions : Active / Not Active.</u>

UserPostedImage

<u>Remark:</u>
When a route is activated/executed is will AUTOMATICALLY have the 'Active' state. This state can be reset by the action 'Set Not Active' defined on a route object in the Actions table of the Actions and Conditions dialog.

- finally, some bug fixing in the 'Route Planner' dialog, program crash.[:I]

Best regards,
Frank
Offline Tivvy  
#247 Posted : 17 November 2008 02:03:58(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Excellent! Thankyou Frank. Downloading it now biggrin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline xxup  
#248 Posted : 17 November 2008 09:38:04(UTC)
xxup

Australia   
Joined: 15/03/2003(UTC)
Posts: 6,815
Location: Australia
You are doing great Frank... I was over at Nev's place on the weekend and he had Lokcommander hooked up via a wireless bridge to his CS1.. It was working great... When we redo his layout early next year, we will add contact tracks and start to experiment with computer control...
Adrian
UserPostedImage
Australia flag by abFlags.com
Offline Tivvy  
#249 Posted : 17 November 2008 10:41:36(UTC)
Tivvy


Joined: 01/02/2008(UTC)
Posts: 414
Location: Melbourne, Victoria
Frank,
When I go to conditions and try to add a route object none of the drop-down lists work and I cant get it to accept the list :S Any ideas as to what might be causing the problem?
I am using Vista SP1 32bit.

Also, what is the purpose of the "armed" box next to the distant signal aspects?
Couldnt find it in the manual.

Caillin
Ep IV / V Marklin Layout
6 track dead end station, twin track loop, 4 track through station.
Under construction.
Offline fvri  
#250 Posted : 17 November 2008 12:50:45(UTC)
fvri


Joined: 07/10/2002(UTC)
Posts: 773
Location: Zwevezele,
Hi Caillin,

Ok, I could reproduce your problem. On my layout it 'was' fine (as you could see in the screenshots) but I made a new 'small' test layout and yes trouble shooting with the route conditions... Sorry did not test hard enough[:I]

I will have a look at it asap for a fix!

About the armed signal type, well it refers to a semaphore signal(the old stuff with the arms).

Thanks for the feedback!

Cheers,
Frank
Users browsing this topic
Guest (2)
7 Pages«<34567>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2014, Yet Another Forum.NET
This page was generated in 2.107 seconds.